Help me, I New in EXPO


#1

I worked with react native and android studio until yesterday, yesterday I installed expo, I tried it and it looked great but I see that now when installing new libraries like react-native-router-flux or firebase it gives me many errors when installing and in the Expo I get this error:

an when I Install new libraries i have always this error or or something similar:

npm WARN react-native-maps@0.12.2 requires a peer of react@>=15.4.0 but none was installed.
npm WARN react-native-svg@4.4.1 requires a peer of react@>=15.4.0 but none was installed.
npm WARN lottie-react-native@1.1.1 requires a peer of react@>=15.3.1 but none was installed.
npm WARN react-native-maps@0.12.2 requires a peer of react@>=15.4.0 but none was installed.
npm WARN react-native@0.41.2 requires a peer of react@~15.4.0 but none was installed.
npm WARN react-native-svg@4.4.1 requires a peer of react@>=15.4.0 but none was installed.
npm WARN react-dom@15.5.4 requires a peer of react@^15.5.4 but none was installed.
npm WARN react-static-container@1.0.1 requires a peer of react@^0.13.0 || ^0.14.0 || ^15.0.0 but none was installed.

Until yesterday all always worked well.

Can somebody help me?


#2

Interesting! It looks like react-native-router-flux depends directly on react-native rather than having it as a peer dependency: https://github.com/aksonov/react-native-router-flux/blob/master/package.json#L44. I expect this would work fine on RN 0.41, but probably needs updating for a current version of React Native.