Hot reloading with Expo XDE

#1

Hi guys,
I started working on an app using Expo a month or so ago.

It’s brilliant!

I do have an issue, though, and am not sure if I should raise a JIRA ticket just yet, as maybe I’m missing something, as I can’t find anything about this error.
Currently using Expo XDE (tried cli exp too), testing my app on two physical devices: Samsung S8 and Iphone 5s.
When hot reloading and having only one device connected, everything works great. However, when I fire up the second device (no matter which one).
Upon JS bundle reload, the device I’ve reloaded from will not break on next HMR update; again, no matter which one I do the described.

Error: ‘Tried to register two views with the same name ExponentCamera’
Expo: Expo XDE/ exp cli, SKD v28.
App: initially TabNavigation boilerplate, now: Redux managed app

PS: I’m not using the Camera module in any way. I am only using { Asset, Font, Icon, FileSystem, Apploading } from the ‘expo’ package.

LE: on Expo 29 it shows me the same error, but regards ExponentBarCodeScanner :sweat_smile:

Anyone came across something like this?
Thanks

1 Like
#2

Hey @kriskate,

I brought this up in our internal slack. Going to have one of our devtool creators take a look and see if they can figure out what could be happening here.

Side note: Have you tried our new devtool yet? If not, I would strongly suggest doing so!

Cheers,

Adam

#3

I’m all over the new devtool :grimacing:, sorta’ combines both tools I’ve been using (depending on my mood).
Used it all day today, seems to have a lower impact on the resources (more ram for Chrome yey).

Well, the LE I’ve put in the initial comment is with expo 29, using the new cli; so what happens now is that it changed from ExponentCamera to ExponentBarCodeScanner.

I forgot to mention I’m also using react-navigation, but that came with the TabNavigation boilerplate anyway.

Thanks

closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.