I am the beginning periods of making an application with Expo


#1

I’m new to react-native and am in the beginning periods of making an application with Expo. I had a working application until introducing redux. Presently I am getting the accompanying mistake from the XDE:

Problem checking node_modules dependencies: Unexpected end of JSON input

and the following from the ios simulator:

Building JavaScript bundle: error
TransformError: ../app/main.js: Couldn't find preset "babel-preset-expo" relative to directory "../app/"

I trust my hub modules contain valid JSON. It ought to be noticed that I’m utilizing a more present version of react-native than expo.

Thanks,
SAILAJA
Teradata Developer


#2

Hey, looks like someone had the same problem here: https://stackoverflow.com/questions/44530407/react-native-install-issue-in-expo-app

There are a couple things you can try – 1) update your npm version (with npm update -g npm) 2) use yarn instead (with yarn install, you may need to install yarn first)


#3

Hi @seveneightn9ne

Thanks for the quick help, will try your proposal definitely!