ios App Update Bug AppStore

#1

I have all my clients, in some version o Expo Detached App (IPA Version X, SDK 26, OTA Updates Enabled)
I’m publishing a new version of the app (IPA Version Y, SDK 26, OTA Updates Disabled)

When an user updates the app from Version X to Version Y the version X have OTA bundles in App User Data, so, when Version Y loads the app we have a error message.

Version Y:

The expected behavior wold be the new app handle the user data excluding old bundle versions.
If the user uninstall and install the app, it works fine.

#2

Hi @victorwads - this sounds like it could be related to https://github.com/expo/expo/issues/1719 . If so, a fix has already been landed internally and will go out very soon.

Could you clarify, when you say you published Version Y, did you also build a new IPA? Or is Version Y simply being downloaded by the user as an OTA update itself?

#3

Hi @esamelson - Yes, i built a new IPA, this print screen is IPA Version Y.

#4

The app should not cause OTA Updates are not Allowed on Constants
The expected behavior is the apps ignore Check OTA Version and use only “IPA Bundled” JS Bundles.
This is Fixed

the best solution (by @esamelson on git hub) is follow instructions to upgrade Ios SDK to 2.5.9

cause i don’t need to re-build and re-publish on app store, I found an easy ugly solution :

  1. The app try to get a new OTA version on the configured channel.
  2. The channel don’t exists on CDN, that the cause of the error!
  3. I published something on the channel, and it works.
closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.