iOS - Release build issue (credentials missing)

#1

Hello,

We are encountering a build issue on our release channel. We have the iOS set up to let Expo handle credentials when building and have been able to successfully build and release our app (in the iOS app store) in the past. However, yesterday, we attempted a release channel build and got the following error message(s)

2018-06-26T20:00:21.3997800Z [20:00:21] We do not have some credentials for you, certP12,certPassword
2018-06-26T20:00:21.4028730Z [20:00:21] Error while gathering & validating credentials
2018-06-26T20:00:21.4063840Z [20:00:21] Input is required, but exp is in non-interactive mode.

We noticed there were a few other users encountering iOS build issues but none of them seem to be missing credentials.

When we run ‘exp fetch:ios:certs’ we get the following errors

[14:48:23] Retreiving iOS credentials for @[user]/[app_name]
[14:48:24] Unable to fetch credentials for this project. Are you sure they exist?

Has anyone else encountered credentials disappearing? I say disappear because we have been able to build in the past with no issues and just recently exp is now saying no credentials exist.

0 Likes

#2

Hi! Have you recently changed any fields in app.json, especially slug or the project name?

0 Likes

#3

Thanks for the response. We have changed the app.json since the previous build. The changes were: added adaptive icon for Android, updated googleMaps API key and modified some splash screen paths. No changes to the name or the slug.

I’m not sure if this matters but the name in the app store is not the same as the “name” value in our app.json.

Edit: we ended up revoking all the certificates, profiles, etc. and starting over. PSA, fetch your iOS certs.

0 Likes

closed #4

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes