java.lang.RuntimeException: Could not load exp://exp.host/@username/project

#1

Hi, I’m getting quite a lot of these errors on Android:


Exception java.lang.RuntimeException: Could not load exp://exp.host/@username/project.
host.exp.exponent.kernel.ExpoViewKernel.handleError (ExpoViewKernel.java:76)
host.exp.expoview.ExponentActivity$1.onError (ExponentActivity.java:109)
host.exp.exponent.ExponentManifest$3.onFailure (ExponentManifest.java:211)
host.exp.exponent.network.ExponentHttpClient.tryHardCodedResponse (ExponentHttpClient.java:124)
host.exp.exponent.network.ExponentHttpClient.access$100 (ExponentHttpClient.java:32)
host.exp.exponent.network.ExponentHttpClient$2.onResponse (ExponentHttpClient.java:95)
okhttp3.RealCall$AsyncCall.execute (RealCall.java:126)
okhttp3.internal.NamedRunnable.run (NamedRunnable.java:32)
java.util.concurrent.ThreadPoolExecutor.runWorker (ThreadPoolExecutor.java:1112)
java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:587)
java.lang.Thread.run (Thread.java:841)
arrow_drop_down
Caused by host.exp.exponent.exceptions.ManifestException:
host.exp.exponent.ExponentManifest$3.onFailure (ExponentManifest.java:211)
host.exp.exponent.network.ExponentHttpClient.tryHardCodedResponse (ExponentHttpClient.java:124)
host.exp.exponent.network.ExponentHttpClient.access$100 (ExponentHttpClient.java:32)
host.exp.exponent.network.ExponentHttpClient$2.onResponse (ExponentHttpClient.java:95)
okhttp3.RealCall$AsyncCall.execute (RealCall.java:126)
okhttp3.internal.NamedRunnable.run (NamedRunnable.java:32)
java.util.concurrent.ThreadPoolExecutor.runWorker (ThreadPoolExecutor.java:1112)
java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:587)
java.lang.Thread.run (Thread.java:841)

As far as I understood if Expo couldn’t load new version of JS code from the server it would run the bundled code, but it seems like those errors lead to fatal crashes. Any advice on how to debug?

Thank you!

Release Android crash with java.lang.RuntimeException
#2

Running into the same problem, did you ever find a solution?

#3

No, still having it even after upgrading to the latest Expo version. There is another thread with the same error: Release Android crash with java.lang.RuntimeException No solution though.

#4

I’m getting the same error.
Any luck on this?

#5

Talked to @jesse on Slack about it. Seems like it’s happening because JS is not bundled with detached app and if there is no internet on initial start the app crashes. Might be fixed in the next release, maybe later.

#6

I’m getting the same error every time when I started my app downloaded from google play store.
On emulator via android studio everything works. Any idea?

#7

This is likely a result of not having an internet connection on the initial load.
There is a feature request to allow standalone apps to run in this context: https://expo.canny.io/feature-requests/p/allow-standalone-apps-to-load-and-function-with-no-internet-connection

#8

any solution for this problem?