My IOS application isn't building using EAS

I receive many of they following types of errors:

ld: warning: directory not found for option ‘-L/Users/expo/Library/Developer/Xcode/DerivedData/Lyferize-gdzglpdnfmzrxhdeaflgiacxwujq/Build/Intermediates.noindex/ArchiveIntermediates/Lyferize/BuildProductsPath/Release-iphoneos/DoubleConversion’

Finally, the build fails with:
ld: library not found for -lDoubleConversion

clang: error: linker command failed with exit code 1 (use -v to see invocation)

Are there any tips on how I can try to debug this?

can you share some information about your project? sdk version, managed or bare, etc…

my project is managed

I’m sdk 40.0.0

I’m using aws amplify

{
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  },
  "dependencies": {
    "@aws-amplify/pushnotification": "^3.2.20",
    "@react-native-async-storage/async-storage": "^1.13.2",
    "@react-native-community/checkbox": "^0.5.6",
    "@react-native-community/datetimepicker": "3.0.4",
    "@react-native-community/masked-view": "0.1.10",
    "@react-native-community/netinfo": "5.9.7",
    "@react-native-community/picker": "1.6.6",
    "@react-native-community/push-notification-ios": "^1.8.0",
    "@react-native-picker/picker": "1.9.2",
    "@react-navigation/bottom-tabs": "^5.11.1",
    "@react-navigation/native": "^5.8.9",
    "@react-navigation/stack": "^5.12.8",
    "aws-amplify": "^3.3.8",
    "aws-amplify-react-native": "^4.2.9",
    "aws-sdk": "^2.839.0",
    "base64-arraybuffer": "^0.2.0",
    "expo": "^40.0.0",
    "expo-av": "~8.7.0",
    "expo-constants": "~9.3.3",
    "expo-image-picker": "~9.2.0",
    "expo-notifications": "~0.8.2",
    "expo-permissions": "~10.0.0",
    "expo-server-sdk": "^3.6.0",
    "expo-status-bar": "~1.0.3",
    "expo-updates": "^0.4.1",
    "exponential-backoff": "^3.1.0",
    "formik": "^2.2.6",
    "graphql-tag": "^2.11.0",
    "moment": "^2.29.1",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz",
    "react-native-create-guid": "^1.1.0",
    "react-native-elements": "^3.0.0-alpha.1",
    "react-native-fs": "^2.16.6",
    "react-native-gesture-handler": "~1.8.0",
    "react-native-image-crop-picker": "^0.35.2",
    "react-native-in-app-notification": "^3.1.0",
    "react-native-logs": "^3.0.2",
    "react-native-modal-datetime-picker": "^9.1.0",
    "react-native-multiple-select": "^0.5.6",
    "react-native-paper": "^4.4.1",
    "react-native-phone-input": "^0.2.4",
    "react-native-picker-select": "^8.0.3",
    "react-native-popup-menu": "^0.15.9",
    "react-native-reanimated": "~1.13.0",
    "react-native-screens": "~2.15.2",
    "react-native-svg": "12.1.0",
    "react-native-uuid-generator": "^6.1.1",
    "react-native-vector-icons": "^7.1.0",
    "react-native-web": "~0.13.12",
    "react-navigation": "^4.4.3",
    "react-navigation-drawer": "^2.6.0",
    "uuid": "^8.3.1",
    "victory-native": "^35.3.1",
    "yup": "^0.32.8"
  },
  "devDependencies": {
    "@babel/core": "~7.9.0"
  },
  "private": true
}

thanks for sharing! we don’t recommend using eas build with managed apps yet, we plan to roll out proper support for that around the end of q1. if you share your build id that could help us investigate further though

we’ve resolved an issue that may have been causing the error that you encountered, feel free to give it another try (although no guarantees given that we don’t fully support managed apps on eas build yet)

Thank you :slight_smile: my build succeeded.