Node version 4.6.1 is not supported, please use Node.js 6.0 or higher


#1

Once I run,

exp start. 

I prints “Node version 4.6.1 is not supported, please use Node.js 6.0 or higher.”

But when I update the node.js 6.0.0, the XDE shows warning


Warning: You are using npm version 5.3.0. There may be bugs in this version, use it at your own risk. We recommend version 4.6.1.

What should I do?? I can’t do ‘exp start’ anyway. :frowning: I can’t run this project…

Thank you for your support


#2

hello, just update the version of your npm.

npm install npm@4.6.1 -g


#3

That just solved the problem…!!! thank you so much.


#4

These are just warnings – we recommend < NPM 5 because of bugs that the NPM team still hasn’t fixed w.r.t. dependencies used by Expo. However, YMMV – it doesn’t necessarily mean Expo won’t work with NPM 5.