NPM install expo issue (fsevents)

#1

Hi I am attempting to npm install a project on a new computer but having issues. Looks like issue is coming from fsevents. Any help would be appreciated. This is the first section of the errors from my terminal:

> fsevents@1.1.3 install /Users/ali/Documents/reactnative/keto/node_modules/fsevents

> node install

node-pre-gyp ERR! Tried to download(404): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.3/fse-v1.1.3-node-v64-darwin-x64.tar.gz

node-pre-gyp ERR! Pre-built binaries not found for fsevents@1.1.3 and node@10.9.0 (node-v64 ABI, unknown) (falling back to source compile with node-gyp)

node-pre-gyp ERR! Tried to download(undefined): https://fsevents-binaries.s3-us-west-2.amazonaws.com/v1.1.3/fse-v1.1.3-node-v64-darwin-x64.tar.gz

node-pre-gyp ERR! Pre-built binaries not found for fsevents@1.1.3 and node@10.9.0 (node-v64 ABI, unknown) (falling back to source compile with node-gyp)

Here is my package.json file:

{
  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "dependencies": {
    "axios": "^0.18.0",
    "expo": "^29.0.0",
    "firebase": "4.12.0",
    "latlng-to-zip": "0.0.1",
    "lodash": "^4.17.5",
    "moment": "^2.22.1",
    "native-base": "^2.4.1",
    "ngeohash": "^0.6.0",
    "qs": "^6.5.1",
    "react": "16.3.1",
    "react-moment": "^0.7.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-29.0.0.tar.gz",
    "react-native-app-intro-slider": "^0.2.4",
    "react-native-elements": "^0.19.0",
    "react-native-image-gallery": "^2.1.5",
    "react-native-modal": "^6.0.0",
    "react-native-phone-call": "^1.0.4",
    "react-native-vector-icons": "^4.6.0",
    "react-navigation": "^2.9.3",
    "react-redux": "^5.0.7",
    "redux": "^3.7.2",
    "redux-thunk": "^2.2.0",
    "uuid": "^3.2.1"
  },
  "devDependencies": {
    "eslint-config-rallycoding": "^3.2.0"
  }
}```
0 Likes

closed #2

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

0 Likes