old bundle being loaded?

#1

I had an error reported to sentry recently that indicated it was running the latest revision (both in the initial console log of the manifest and in sentry context), but all other aspects of the error indicate that it’s running an older revision. It was reported with an older sentry sdk and the format of the breadcrumb and error match that of older revisions since I updated sentry-expo to the latest version and changed the way breadcrumbs and that specific error are formatted a few revisions ago. There are other errors on the same revision that are using the correct sentry sdk and breadcrumb/error format so I don’t believe the wrong code was published.

Is there any way a bundle mismatch is possible? I’m on a detached sdk 24 expokit project and the user was running ios v2.2.1 of expoview.

#2

Hi @alxyuu1. Was this on iOS or Android? Also when you say

both in the initial console log of the manifest

does that mean that you think the bundle and the manifest version are out of sync?

#3

yes, the bundle and manifest version are out of sync.

I mentioned earlier that the user was running iOS, expoview v2.2.1 on sdk 24.

The manifest claims to have a published time of June 1st, but I published the sentry changes 3 weeks ago.

#4

Ok, we made some changes to code loading after SDK 24, so I’d recommend updating if possible. Sorry about that. With the new changes the manifest and the bundle shouldn’t get out of sync.

closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.