outdated dependancy requirement on fresh expo install?

Please provide the following:

  1. SDK Version: latest!
  2. Platforms(Android/iOS/web/all): android

Fresh new blank app with some minor content added to it, installed needed dependencies this is the warning I get:

Some of your project’s dependencies are not compatible with currently installed expo package version:

  • react-native-safe-area-context - expected version range: ~3.0.7 - actual version installed: ^3.1.1
    Your project may not work correctly until you install the correct versions of the packages.
    To install the correct versions of these packages, please run: expo install [package-name …]

I am just curious why on the earth is expo working with outdated dependancies? Last month I had severe issues with expo/RN and their bs and now I just want to know whats going on that an updated expo is asking for outdated dependency.

  • I got an error on this fresh install when trying to open on android device…
    Error: Unable to resolve module ./node_modules\expo\AppEntry from ``:

None of these files exist:

  • node_modules\expo\AppEntry(.native|.android.expo.ts|.native.expo.ts|.expo.ts|.android.expo.tsx|.native.expo.tsx|.expo.tsx|.android.expo.js|.native.expo.js|.expo.js|.android.expo.jsx|.native.expo.jsx|.expo.jsx|.android.ts|.native.ts|.ts|.android.tsx|.native.tsx|.tsx|.android.js|.native.js|.js|.android.jsx|.native.jsx|.jsx|.android.json|.native.json|.json|.android.wasm|.native.wasm|.wasm|.android.vue|.native.vue|.vue)
  • node_modules\expo\AppEntry/index(.native|.android.expo.ts|.native.expo.ts|.expo.ts|.android.expo.tsx|.native.expo.tsx|.expo.tsx|.android.expo.js|.native.expo.js|.expo.js|.android.expo.jsx|.native.expo.jsx|.expo.jsx|.android.ts|.native.ts|.ts|.android.tsx|.native.tsx|.tsx|.android.js|.native.js|.js|.android.jsx|.native.jsx|.jsx|.android.json|.native.json|.json|.android.wasm|.native.wasm|.wasm|.android.vue|.native.vue|.vue)
    at ModuleResolver.resolveDependency (/Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/node-haste/DependencyGraph/ModuleResolution.js:163:15)
    at ResolutionRequest.resolveDependency (/Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/node-haste/DependencyGraph/ResolutionRequest.js:52:18)
    at DependencyGraph.resolveDependency (/Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/node-haste/DependencyGraph.js:287:16)
    at /Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/lib/transformHelpers.js:267:42
    at Server. (/Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/Server.js:841:41)
    at Generator.next ()
    at asyncGeneratorStep (/Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/Server.js:99:24)
    at _next (/Users/tadejhiti/natekmi/natekmi/node_modules/metro/src/Server.js:119:9)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)

this does not work: