Peer dependencies are not satisfiable

#1

Hi! I’ve been working on an Expo 30 upgrade for one of our apps, and I noticed something in the peer dependencies.

Thanks for breaking up the big expo dependency in 30, that should delight a lot of developers :smiley:. I’ve noticed that both the expo-camera@1.1.0 as well as expo-gl@1.0.2 requires peer dependency react@^16.4.0. But, Expo 30 should have been locked to 16.3.1 (right?). It’s not really a “bug” for me, and it’s probably fixed in a later Expo version. But because that might be ±1 month away, I think either one should be aligned.

Cheers!
Cedric

closed #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.