Problem building apk

Hi @wkozyra

You sent me this message, but the truth is that I am still confused and I really want to understand what I should do and not repeat the mistakes.

I try to put you in context to see if you find it easier to guide me.

The first apk I built I uploaded manually and it is published without problem.

After I tried to build again to upload an update, he asked me for the data that I put below, the truth I answered without being sure and from there, I could not do anything else.

Configuring credentials for aasprilla in project Brokerhoods
✔ Would you like to upload a Keystore or have us generate one for you?
If you don't know what this means, let us generate it! :) › I want to upload my own file

WARNING! In this mode, we won't be able to make sure that your credentials are valid.
Please double check that you're uploading valid files for your app otherwise you may encounter strange errors!

When building for IOS make sure you've created your App ID on the Apple Developer Portal, that your App ID
is in app.json as `bundleIdentifier`, and that the provisioning profile you
upload matches that Team ID and App ID.

✔ Path to the Keystore file. … /Users/anibalasprilla/api-8771518372671769047-141674-fed06d34fc37.json
✔ Keystore password … *************
✔ Key alias … aalteam-android71071301146
✔ Key password … *************
Keystore updated successfully

This is my configuration:

Thats
Expo CLI 3.21.13 environment info:
    System:
      OS: macOS Mojave 10.14.6
      Shell: 3.2.57 - /bin/bash
    Binaries:
      Node: 12.16.3 - /usr/local/bin/node
      Yarn: 1.22.4 - /usr/local/bin/yarn
      npm: 6.14.4 - /usr/local/bin/npm
    IDEs:
      Android Studio: 3.5 AI-191.8026.42.35.6010548
      Xcode: 11.3.1/11C504 - /usr/bin/xcodebuild
    npmPackages:
      expo: ~38.0.8 => 38.0.8
      react: ~16.11.0 => 16.11.0
      react-dom: ~16.11.0 => 16.11.0
      react-native: https://github.com/expo/react-native/archive/sdk-38.0.1.tar.gz => 0.62.2
      react-native-web: ~0.11.7 => 0.11.7
    npmGlobalPackages:
      expo-cli: 3.21.13

This is my google account:

With this information, how can I solve the problem?

Thank you very much for your support and patience.

This was your last message, so I remain attentive to your indications …

  • if you have keystore somwhere, just specify it by running expo build:android -c and passing all values manually
  • if you don’t have one, run expo build:android -c -> wait for the build end -> run expo fetch:android:upload-cert -> send pem file generated by last command to google support to reset your password

Thanks in advance!

When you run expo build:android the first time I assume that you selected option to let's expo handle it, during build Keystore was generated and stored on expo servers, if you uploaded that apk to play store then all future builds need to be signed with the same Keystore.

expo-cli asked you that question again because somehow there was no keystore assigned for this app, there are few potential reasons how this could happen

  • expo build:android --clear-credentials
  • changing slug in app.json
  • setting owner field in app.json to a different team

soon file you uploaded (and I assume passwords and alias) have nothing to do with keystore, so the process of signing is failing.

If the issue was changing the slug or owner field you can change it back and recover keystore with expo fetch:android:keystore, but if you cleared those credentials the only way is to ask google play support to reset your keystore. In that case, you will need to send them pem file extracted from the new keystore. I explained how to generate it in the previous message

run expo build:android -c 
-> wait for the build end 
-> run expo fetch:android:upload-cert 
-> send pem file generated by last command to google support to reset your keystore

Thanks friend @wkozyra

I proceed to make the indications, if I have any news on the way I will let you know.

Hi @wkozyra

I tried, but I got this…

MBP-de-ANIBAL-2:Brokerhoods anibalasprilla$ expo build:android -c
┌─────────────────────────────────────────────────────────────────────────┐
│                                                                         │
│   There is a new version of expo-cli available (3.22.0).                │
│   You are currently using expo-cli 3.21.13                              │
│   Install expo-cli globally using the package manager of your choice;   │
│   for example: `npm install -g expo-cli` to get the latest version      │
│                                                                         │
└─────────────────────────────────────────────────────────────────────────┘
✔ Choose the build type you would like: › apk
Checking if there is a build in progress...

Configuring credentials for aasprilla in project Brokerhoods
There is no valid Keystore defined for this app
? Would you like to upload a Keystore or have us generate one for you?
If you don't know what this means, let us generate it! :) › - Use arrow-keys. Return to submit.
❯   Generate new keystore
    I want to upload my own file

Thaks for your support!

Select Generate new keystore

I mistyped in a last instruction
I meant

send pem file generated by last command to google support to reset your keystore

not

send pem file generated by last command to google support to reset your password

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.