Problem with running old version of create-react-native-app

I am taking the React Native course on Coursera (https://www.coursera.org/learn/react-native). Unfortunately the course uses a very old version of Expo SDK and create-react-native-app. It uses version 1.0.0 of create-react-native-app.

I was able to create a new project using create-react-native-app@1.0.0. When I try to run the app on an Android emulator, it installs the Expo client app on the emulator and tries to open the project, but gives an error message. Please see attached screenshot.

The error suggests that the Expo client app cannot open projects created with Expo SDK 25.

Is it possible to run projects created with create-react-native-app version 1.0.0 ?.

I tried to use an old version of the Expo client. I downloaded the source code of release: ios/1.15.2 from: https://github.com/expo/expo/releases?after=ios%2F1.19.1.

I followed the instructions in the README.md file and installed node version 7.0.0 and npm version 3.10.8. I ran the npm install command from the js/ folder and it completed without errors. But when I ran the npm install command from the tools-public/ folder, it gave the following error:

nadir@nadir-X551MA:~/Projects/mobile/expo/tools-public$ npm install
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm ERR! git rev-list -n1 4.0: fatal: ambiguous argument '4.0': unknown revision or path not in the working tree.
npm ERR! git rev-list -n1 4.0: Use '--' to separate paths from revisions, like this:
npm ERR! git rev-list -n1 4.0: 'git <command> [<revision>...] -- [<file>...]'
npm ERR! git rev-list -n1 4.0: 
npm ERR! git rev-list -n1 4.0: fatal: ambiguous argument '4.0': unknown revision or path not in the working tree.
npm ERR! git rev-list -n1 4.0: Use '--' to separate paths from revisions, like this:
npm ERR! git rev-list -n1 4.0: 'git <command> [<revision>...] -- [<file>...]'
npm ERR! git rev-list -n1 4.0: 
npm WARN addRemoteGit Error: Command failed: git config --get remote.origin.url

My operating system is Ubuntu 20.04.

Current versions of the Expo app do not support SDK versions older than SDK 36.

It seems to me you will have more luck by installing a more recent version of node (at least 10) and the latest expo-cli.

Depending on exactly what functionality they are making use of in the course, it might not be too hard to figure out any changes that might be needed to get the old code to work in current versions of Expo.

If you get stuck you could post questions in the “Expo SDK” category about things you are having trouble upgrading.

Ok. Thanks

Are you managing? :slight_smile:

Yes. So far so good. I am following the course instructions and making minor changes to the old code in the instructions.

1 Like