Problems Installing Expo

Hey, I have been trying to install expo but I got the following error messages below. My questions are what are the best ways to go about installation and how to update expo-cli successfully? Lastly, in my expo app, the error message “Metro Bundler has encountered an internal error” often pops up. How do I go about fixing this error?

Installing Expo CLI failed. You can install it manually with:
npm install --global expo-cli
npm ERR! code ELIFECYCLE
npm ERR! errno 4294963248
npm ERR! TheProject@1.0.0 start: expo start
npm ERR! Exit status 4294963248
npm ERR!
npm ERR! Failed at the TheProject@1.0.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!

Hey @tobiappdeveloper,

What environment are you working with? Running npm install -g expo-cli should work just fine. You can also use yarn but it’s up to preference.

Cheers,
Adam

I can only install expo cli successfully when I run node js as an administrator. Otherwise it doesn’t work for me