Problems with try exp-cli on Genymotion android 8 - I solved it using Expo XDE because I couldn't it using exp-cli

#1

Hi, I have problem when I try to install exp-cli on Genymotion Galaxy S8 emulator with Android 8:

$ exp install:android
[21:40:02] Uninstalling Expo from Android device.
[21:40:02] Exception occurred while executing:
java.lang.IllegalArgumentException: Unknown package: host.exp.exponent
	at com.android.server.pm.Settings.isOrphaned(Settings.java:4400)
	at com.android.server.pm.PackageManagerService.isOrphaned(PackageManagerService.java:21424)
	at com.android.server.pm.PackageManagerService.deletePackageVersioned(PackageManagerService.java:18498)
	at com.android.server.pm.PackageInstallerService.uninstall(PackageInstallerService.java:913)
	at com.android.server.pm.PackageManagerShellCommand.runUninstall(PackageManagerShellCommand.java:912)
	at com.android.server.pm.PackageManagerShellCommand.onCommand(PackageManagerShellCommand.java:134)
	at android.os.ShellCommand.exec(ShellCommand.java:96)
	at com.android.server.pm.PackageManagerService.onShellCommand(PackageManagerService.java:21727)
	at android.os.Binder.shellCommand(Binder.java:573)
	at android.os.Binder.onTransact(Binder.java:473)
	at android.content.pm.IPackageManager$Stub.onTransact(IPackageManager.java:2644)
	at com.android.server.pm.PackageManagerService.onTransact(PackageManagerService.java:3485)
	at android.os.Binder.execTransact(Binder.java:674)

Can someone help me? Thanks.

#2

Hi @atiladev - which version of exp are you running (exp --version)? And did you say this is working correctly for you when using XDE?

#3

$ exp --version
55.0.4

Expo XDE:
Versión 2.24.4 (2.24.4.53441)

#4

Hi @atiladev - does this happen for you on other Genymotion devices, or when using Android Studio emulators?

You can install the app manually by going to https://exp.host/--/api/v2/versions, downloading the apk listed at “androidUrl” and then running adb install <downloaded-location>.

#5

I use two images in Genymotion, one with Galaxy S6 with Android 7 and it works perfectly, and the one that did not work (it was solved), that a Galaxy S8 with Android 8.

Same thank you very much for the indication.

Greetings.

closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.