[PUSH NOTIFICAITON - PHP] alymosul/exponent-server-sdk-php

#1

Hi,

I am trying to install push notification package to my server.

Since I am using PHP for the server scripting, I need to use PHP package.

composer require alymosul/exponent-server-sdk-php

Above command line is not working although current PHP version is above 7.0.

It shows

[InvalidArgumentException] Package alymosul/exponent-server-sdk-php at version has a PHP requirement incompatible with your PHP version (5.6.36)

php -v

ea-php-cli Copyright 2017 cPanel, Inc. PHP 7.0.30 (cli) (built: Jul 17 2018 16:50:03) ( NTS ) Copyright (c) 1997-2017 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
It shows PHP version, and it is compatible.

Any idea?

closed #2

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.