pusher-js + expo + react-native-community/netinfo = bad

Please provide the following:

  1. SDK Version:
    36.0.0
  2. Platforms(Android/iOS/web/all):
    android and web (not tested on ios)

Hey guys, I’m trying to connect to a websocket service we have on Pusher, using their library pusher-js for react-native.

From what I understand, this library depends on @react-native-community/netinfo for some network operations and something is breaking. I’m getting this error:

RNCNetInfo.getCurrentState got 3 arguments, expected 2

I tried these solutions:

  • use expo install to get the appropriate version that is supposed to be compatible (4.6.0) of netinfo
  • locked on many older versions that I found in solutions online (from 4.1.1 to 5.0.0, to the latest)
  • cleaned caches, deleted node-modules and all of that.

the only thing I haven’t tried is switching to yarn and/or ejecting (which I REALLY would like to avoid…)

does anybody have any other ideas?

1 Like