react-native-file-viewer throwing error : 'Native modules cannot be null'

Hi Expo Team ,
i am facing error on library installation : react-native-file-viewer

  1. SDK Version: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz
  2. Platforms(Android/iOS/web/all): All

I am trying to install react-native-file-viewer to mu expo app using yarn add
It get installed but when i am importing it throws error as Native Modules can not be null .

Providing you the snack link for seeing error live : https://snack.expo.io/@gd_11/3f8de6

i am attaching my package.json for reference:

“dependencies”: {
@react-native-community/datetimepicker”: “2.2.2”,
@react-native-community/masked-view”: “0.1.6”,
@react-navigation/bottom-tabs”: “^5.2.8”,
@react-navigation/material-top-tabs”: “^5.1.10”,
@react-navigation/native”: “^5.1.6”,
@react-navigation/stack”: “^5.2.19”,
“apisauce”: “^1.1.1”,
“expo”: “~37.0.3”,
“expo-file-system”: “^9.0.1”,
“expo-local-authentication”: “~9.0.0”,
“expo-localization”: “~8.1.0”,
“i18n-js”: “^3.5.1”,
“moment”: “^2.25.3”,
“react”: “~16.9.0”,
“react-dom”: “~16.9.0”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz”,
“react-native-animatable”: “^1.3.3”,
“react-native-appearance”: “^0.3.3”,
“react-native-dropdown-picker”: “^3.1.6”,
“react-native-file-viewer”: “^2.1.1”,
“react-native-gesture-handler”: “~1.6.0”,
“react-native-modal-datetime-picker”: “^8.6.0”,
“react-native-reanimated”: “^1.7.0”,
“react-native-responsive-screen”: “^1.4.1”,
“react-native-safe-area-context”: “0.7.3”,
“react-native-screens”: “~2.2.0”,
“react-native-tab-view”: “^2.14.0”,
“react-native-vector-icons”: “^6.6.0”,
“react-native-web”: “~0.11.7”,
“react-native-webview”: “8.1.1”,
“react-redux”: “^7.2.0”,
“redux”: “^4.0.5”,
“redux-mock-store”: “^1.5.4”,
“redux-persist”: “^6.0.0”,
“redux-saga”: “^1.1.3”,
“reduxsauce”: “^1.1.2”
}

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.