[resolved] App doesn't seem to be using updated SDK


#1

Hey! I just updated an app to 18.0.1 following the guide in the release post

I then closed the app + the Expo app on my Android, rebuilt the project, and reopened the app.

It looks like v18 added a base64 prop on images from ImagePicker, but it’s not showing up — any ideas? possible that I’ve just got the workflow wrong - could the Android app be using v17 still?

const result = await ImagePicker.launchCameraAsync(...);
console.log(result)
{
  "cancelled": false,
  "height": 2024,
  "uri": "file:///data/user/0/host.exp.exponent/cache/ExperienceData/%2540jongold%252Fdoggocam/ImagePicker/cf954420-b936-411e-95aa-c485aafd8121.jpg",
  "width": 1518,
}

#2

What version of the Expo Client app do you have? It should be something similar to 1.17.0.


#3

1.17.0 — the Play Store ‘what’s new’ section says ‘support for Expo SDK 18’


#4

Yup looks good. Are you adding the base64: true option to your launchCameraAsync method?


#5

:flushed: I can’t read. thank you!


#6

Good luck with your project! :smile: