Running exp build:ios is not working

#1

Hey guys,

I’m trying to run exp build:ios but I’m getting this weird error:

? How would you like to upload your credentials?
 Expo handles all credentials, you can still provide overrides

We need your Apple ID/password to manage certificates and
provisioning profiles from your Apple Developer account.

Note: Expo does not keep your Apple ID or your Apple password.

? What's your Apple ID? *******
? Password? [hidden] *******
12:29:36 [exp] Validating Credentials...
12:29:40 [exp] Error while gathering & validating credentials
12:29:40 [exp] Error: Reason:Unknown reason, raw:"{\"authType\"=>\"sa\"}\naa=7FCD79CA5234D3E5B95CDBA294E44647; Domain=idmsa.apple.com; Path=/; Secure; HttpOnly, dslang=US-EN; Domain=apple.com; Path=/; Secure; HttpOnly, site=USA; Domain=apple.com; Path=/; Secure; HttpOnly, acn01=8yy+v/6KzWN5UDbE01vja/aneaGkABBSXvonB9w=; Max-Age=31536000; Expires=Wed, 22-May-2019 18:29:40 GMT; Domain=apple.com;Path=/; Secure; HttpOnly"
12:29:40 [exp] Reason:Unknown reason, raw:"{\"authType\"=>\"sa\"}\naa=7FCD79CA5234D3E5B95CDBA294E44647; Domain=idmsa.apple.com; Path=/; Secure; HttpOnly, dslang=US-EN; Domain=apple.com; Path=/; Secure; HttpOnly, site=USA; Domain=apple.com; Path=/; Secure; HttpOnly, acn01=8yy+v/6KzWN5UDbE01vja/aneaGkABBSXvonB9w=; Max-Age=31536000; Expires=Wed, 22-May-2019 18:29:40 GMT; Domain=apple.com; Path=/; Secure; HttpOnly"
12:29:40 [exp] Error: Reason:Unknown reason, raw:"{\"authType\"=>\"sa\"}\naa=7FCD79CA5234D3E5B95CDBA294E44647; Domain=idmsa.apple.com; Path=/; Secure; HttpOnly, dslang=US-EN; Domain=apple.com; Path=/; Secure; HttpOnly, site=USA; Domain=apple.com; Path=/; Secure; HttpOnly, acn01=8yy+v/6KzWN5UDbE01vja/aneaGkABBSXvonB9w=; Max-Age=31536000; Expires=Wed, 22-May-2019 18:29:40 GMT; Domain=apple.com;Path=/; Secure; HttpOnly"
    at Object._callee4$ (/exp@54.0.0/src/commands/build/auth.js:127:11)
    at tryCatch (/usr/local/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:62:40)
    at Generator.invoke [as _invoke] (/usr/local/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:296:22)
    at Generator.prototype.(anonymous function) [as next] (/usr/local/lib/node_modules/exp/node_modules/regenerator-runtime/runtime.js:114:21)
    at step (/usr/local/lib/node_modules/exp/node_modules/babel-runtime/helpers/asyncToGenerator.js:17:30)
    at /usr/local/lib/node_modules/exp/node_modules/babel-runtime/helpers/asyncToGenerator.js:28:13
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)

I’ve seen other related topics but this seems a bit different. For example, if I put in an user/password combination that’s incorrect I’ll get an Invalid credentials error telling me that the user and password I provided aren’t correct.

My Apple user is an Agent (a brand new account, it was enabled a couple of weeks ago) and we don’t have any other users. What could be happening?

2 Likes
#2

Hi eqbquad, I’m actually not sure - @nicknovitski, is this possibly related to fastlane?

expo build:ios (on Windows 10) gets: Error while gathering & validating credentials
#3

Just connect to https://appleid.apple.com/ or http://itunesconnect.apple.com and accept the privacy update.

Taken from: https://stackoverflow.com/questions/50458774/expo-buildios-fails-with-error-while-gathering-validating-credentials

#4

That was it! :smiley:
Thank you very much!

closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.