SDK 18 Networking.sendrequest got 9 arguments, expected 8

#1

I am tring to use the newest expo SDK, but I receive this error. It worked with SDK 17

“dependencies”: {

"expo": "^18.0.4",
"react": "16.0.0-alpha.12",
"react-native": "https://github.com/expo/react-native/archive/sdk-18.0.1.tar.gz",
"react-navigation": "^1.0.0-beta.11",

"@expo/ex-navigation": "^3.0.0",
"@expo/react-native-fade-in-image": "^1.1.1",
"@expo/react-native-image-gallery": "^1.0.4",
"@expo/react-native-read-more-text": "^1.1.0",
"@expo/react-native-touchable-native-feedback-safe": "^1.1.2",
"@expo/vector-icons": "^5.0.0",

"days": "^1.1.0",
"geolib": "^2.0.22",
"immutable": "^3.8.1",
"lodash": "^4.17.4",
"react-native-root-modal": "^1.1.1",
"react-redux": "^5.0.5",
"redux": "^3.7.0",
"redux-effex": "^1.1.2",

"time-js": "0.0.5"

}

#2

hello! It looks like you may have forgotten to update sdkVersion to 18.0.0 in app/exp.json

#3

my project was detached during version 17, i figure out that the .expo-source/android/maven/host/exp/exponent/expoview/ still having 17.0.0 and not updating to 18.0.0

how to update to 18 for project detached since 17?

#4
exp.json
{
  "name": "modelhouz",
  "description": "ModelHouz",
  "slug": "modelhouz",
  "privacy": "unlisted",
  "sdkVersion": "18.0.0",
  "version": "1.0.0",
  "orientation": "portrait",
  "primaryColor": "#cccccc ",
  "icon": "./assets/icons/app.png",
  "loading": {
    "backgroundColor": "#000000 ",
    "icon": "./assets/icons/loading.png",
    "hideExponentText": true
  },
  "packagerOpts": {
    "assetExts": [
      "ttf",
      "mp4"
    ]
  },
  "ios": {
    "supportsTablet": true,
    "bundleIdentifier": "com.modelhouz.model"
  },
  "android": {
    "package": "com.modelhouz.model"
  },
  "isDetached": true,
  "detach": {
    "scheme": "expf49a4056d21242f9973c4376d4627f00",
    "androidExpoViewUrl": "https://s3.amazonaws.com/exp-exponent-view-code/android-v1.17.0-sdk18.0.0-ae92e56e-0f28-44e6-818f-6eec24e05e95.tar.gz",
    "iosExpoViewUrl": "https://s3.amazonaws.com/exp-exponent-view-code/ios-v1.17.0-sdk18.0.0-b4aff885-a9a8-4733-9fa9-ec28bef01e15.tar.gz"
  }
}
#5

Yes, that solved my problem. Thanks!

#6

ok my fault… should have follow the doc before trying it myself.

https://docs.expo.io/versions/v18.0.0/guides/expokit.html#upgrading-expokit

#7

same error and I haven’t did anything , it was working fine yesterday!