SDK 22.0.0 Splash Screen background color issue


#1

I want to set my Splash screen color to #0066cc, but the background just show an white background. The image works fine.

Here is my app.json:
{
“expo”: {
“sdkVersion”: “22.0.0”,
“icon”: “./images/icone_app.png”,
“slug”: “safegive”,
“notification”: {
“icon”: “./images/icone_app_white.png”,
“color”:"#0066cc"
},
“loading”: {
“backgroundColor”: “#FF0000”,
“hideExponentText”: true,
“icon”: “./images/loading.png”,
“splash”: {
“backgroundColor”: “#FBFFC0”,
“image”:"./images/splashinit.png"
}
},
// “splash”: {
// “image”: “./images/splashinit.png”,
// “backgroundColor”: “#FEF9B0
// },
// “loading”: {
// “hideExponentText”: true,
// “icon”: “./images/loading.png”,
// “backgroundImage”: “./images/splashinit.png”,
// “backgroundColor”:"#000000",
// },
“orientation”: “portrait”,
“primaryColor”: “#0066cc”,
“packagerOpts”: {
“assetExts”: [
“ttf”
]
},
“ios”: {
“bundleIdentifier”: “br.com.safegive”,
“supportsTablet”:false

 },
 "android": {
  "package": "br.com.safegive"
},

“androidStatusBar”:{
“backgroundColor”:"#0066cc",

“barStyle”:“light-content”
}
}
}


#2

It looks like you may have the splash key in the wrong place:
https://docs.expo.io/versions/latest/guides/configuration.html#splash

This works for me

{
  "expo": {
    "sdkVersion": "22.0.0",
    "icon": "./assets/icons/app-icon.png",
    "slug": "safegive",
    "notification": {
      "icon": "./assets/icons/app-icon.png",
      "color": "#0066cc"
    },
    "splash": {
      "backgroundColor": "#FBFFC0",
      "image": "./assets/icons/loading-icon.png"
    },
    "orientation": "portrait",
    "primaryColor": "#0066cc",
    "packagerOpts": {
      "assetExts": ["ttf"]
    },
    "ios": {
      "bundleIdentifier": "br.com.safegive",
      "supportsTablet": false
    },
    "android": {
      "package": "br.com.safegive"
    },
    "androidStatusBar": {
      "backgroundColor": "#0066cc",

      "barStyle": "light-content"
    }
  }
}

:blue_heart::blue_heart::blue_heart:


#3

This is the actual app.json, and till doesn’t working …
{
“expo”: {
“sdkVersion”: “22.0.0”,
“icon”: “./images/icone_app.png”,
“slug”: “safegive”,
“notification”: {
“icon”: “./images/icone_app_white.png”,
“color”: “#0066cc
},
“splash”: {
“backgroundColor”: “#FBFFC0”,
“image”:"./images/splashinit.png"
},
“orientation”: “portrait”,
“primaryColor”: “#0066cc”,
“packagerOpts”: {
“assetExts”: [“ttf”]
},
“ios”: {
“bundleIdentifier”: “br.com.safegive”,
“supportsTablet”: false
},
“android”: {
“package”: “br.com.safegive”
},
“androidStatusBar”: {
“backgroundColor”: “#0066cc”,

  "barStyle": "light-content"
}

}
}

This is a print, i want the background to be blue, but it still white,


#4

I had this same issue once I updated to v23, even though I’d changed nothing involving the icons/etc. It still displays with a white screen in dev, but once I build the stand-alone version it’s fine. ¯_(ツ)_/¯


#5

I’m having this issue with SDK 24.0.0 when I build the iOS standalone app. Did you find any fixes?