SDK 30: Splash Screen Got Frozen in Standalone App


#1

My app, which is using SDK 30, works well in expo demo, however, in iOS standalone app, the splash screen got frozen forever. There are the same issues in the previous SDK such as 29 and 28, yet I was able to find a solution for 30. Could anyone help me with this problem?

app.json

{
  "expo": {
    "name": "XXXXXXX",
    "description": "XXXXXXX",
    "slug": "XXXXXXX",
    "privacy": "public",
    "sdkVersion": "30.0.0",
    "platforms": ["ios", "android"],
    "version": "1.0.4",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    },
    "updates": {
      "fallbackToCacheTimeout": 0
    },
    "assetBundlePatterns": [
      "**/*"
    ],
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "XXXXXXX"
    }
  }
}

package.json

{
  "name": "empty-project-template",
  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject"
  },
  "dependencies": {
    "@expo/vector-icons": "^6.3.1",
    "expo": "^30.0.1",
    "react": "16.3.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-30.0.0.tar.gz",
    "firebase": "^5.3.0",
    "moment": "^2.22.2",
    "react-native-datepicker": "^1.7.2",
    "react-native-elements": "^0.19.1",
    "react-native-flags": "^1.0.0",
    "react-native-keyboard-aware-scrollview": "^2.0.0",
    "react-native-material-dropdown": "^0.11.1",
    "react-native-modal-filter-picker": "^1.3.4",
    "react-navigation": "^2.13.0",
    "react-redux": "^5.0.7",
    "redux": "^4.0.0",
    "redux-devtools-extension": "^2.13.2"
  }
}

Standalone app stuck on loading screen
#2

After posting this, I have found an issue about the same problem in Github. I think I should follow that.


#3

same problem here. reported it in Stuck on splashscreen after updating to 30


#4

Same problem ugh. I don’t understand why they didn’t mark a big RED that expo is now splitting off modules. That is a huge breaking change for standalone apps.


#5

The issue should be gone now.

@ericjames there is no breaking change for standalones.


closed #6

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.