SDK 38 | expo eject | problems with running Android

Hello!

In case of some problems with background-location in managed workflow (not working with Android API29), i need to ASAP eject to bare project :frowning:

I don’t have a lot of experience with bare workflow, and I have some problems with running the project.

After running npx react-native run-android i have this kind of errors Pastebin Link

After gradlew --warning-mode all It shows me this Pastebin Link

There is a line that says

> Configure project :expo-constants
The maven plugin has been deprecated. This is scheduled to be removed in Gradle 7.0. Please use the maven-publish plugin instead.
        at build_489d1prt0lpum1niw7yxn8lbh.run(C:\Projects\Myapp-app-app\node_modules\expo-constants\android\build.gradle:2)
        (Run with --stacktrace to get the full stack trace of this deprecation warning.)

I had same problem with ‘expo-battery’, and ‘expo-camera’ or similar packages, but i just removed these packages. removing ‘expo-constants’ doesn’t work with this one.

I’ve been trying to reinstall expo-cli, unimodules, package.json etc.

Android simulator is probably configured well, because I have tried to run new react-native project, and it works fine.

Can somebody help me with running the project? I will be thankfull forever