SDK21 and apple idfa?!


#1

Hey!

I updated the expo sdk from 20 to 21 and wanted to push the new Version of my app to the apple-store.

While i’m doing this, itunesconnect asks if i’m using AD-ID (IDFA). In the last versions i always cliked “no” because i’m not using any ads or something and it worked.

Now i wanted to upload the new version of my app, but itunesconect says that i’m using Ad-ID and i can not click “no”.
I HAVE TO click “yes, i’m using ad-id” and also for what:

  • using ads
  • installations for the app via ads
  • track actions via ads

I could post a screenshot, but it is in german, so i think it does not help… :sweat_smile:


#2

The information on this is in the docs, see Building Standalone Apps. It’s under section 6, “Submit it to the appropriate store”.

Essentially, you have to check “yes” for that option because Expo provides access to Segment under the hood. I put an Expo app through the app store recently and I checked the third option, “Attribute an action taken within this app to a previously served advertisement”, as that seems to line up best with Segment’s use case.

Hope this helps!


#3

Thank you very much, i did not see that note.
I tried your way, i hope it’ll work.

I was just wondering, because it was the first time apple asks for these informations and i only updated the sdk from 20 to 21.

Now i have to wait for apples response :slight_smile:


#4

No worries, this sort of stuff was pretty hard for me to find at first. I hope the review goes well for you! :slight_smile:


#5

fyi: I just recieved the message, that everything seems fine :slight_smile: :tada: