Set minimum SDK for Android

#1

I can’t get TLS1.2 to work with Expo and Android 4.4, so I want to limit my app to Android 5.0 and above. I can’t find any way to configure the minimum Android SDK level for my app. Is this impossible with Expo? It looks really bad when the app store listing says that the app supports Android 4.4, and then it doesn’t work after the user installs it.

#2

I found this on the internet, It was actually posted by one of the developers of Expo:

I think you might be mixing up Expo SDK versions with Android SDK versions. All versions of the Expo SDK support Android 4.4 and greater. If you want to control these fields more directly I would recommend detaching and building your app with ExpoKit – you’ll get full control over the Play Store metadata that way.

By detaching you can adjust all settings as you normally would with a Android project. I am not sure if there is another way right now.

#3

Kinda crazy if I have to detach just to do this. I would like to avoid detaching as long as I can. The hassle-free build process is one of the best things about Expo, loosing that would suck.

#4

I created a feature request for you here: https://expo.canny.io/feature-requests/p/customize-minimum-sdk-version-when-building-for-android

2 Likes
#5

I take it that it isn’t actually possible then. Thanks for pointing me in the right direction.

#6

you can do it but you’re right that you’d lose out on the build process simplicity. you can follow the steps here to do what happens on our build service https://github.com/expo/expo#standalone-apps

2 Likes
closed #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.