[Solved] Native prop error


#1

I get this error after updating to react-native 0.48.1:

`ScrollView` has no propType for native prop `RCTScrollView.onScrollAnimationEnd` of native type `BOOL`
If you haven't changed this prop yourself, this usually means that your versions of the native code and JavaScript code are out of sync. Updating both should make this error go away.

Usually, this could be fixed with restaring packager, clearing cache, reinstalling watchman… But I tried everything and now i ran out of ideas.

It only happens on the ios simulator, but not on android device.


#2

I found the issue:

I upgraded react-native to 0.48.1 but expo sdk 20 ist still on react-native 0.47.1.

Best to look at this chart when upgrading versions:


#3

I got the same Issue, I had been using correct versions of expo & RN but suddenly this error started to pop.
I am using “expo”: “^20.0.0”,

I’ve tried the following versions.
“react-native”: “^0.47.2”,
“react-native”: “^0.47.1”,

I’ve tried the following versions.
“react-native”: “^0.47.2”,
“react-native”: “^0.47.1”,
“react-native”: “^0.47.0”,

@macrozone Were you able to resolve this issue, If yes - how ?


#4

resolved, by updating the packages.

“expo”: “^21.0.0”,
“react”: “16.0.0-alpha.12”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-21.0.2.tar.gz”,


#5

@harryp How did you solve it? Not sure what you mean on the react-native version with that file. And what about the other dependencies in package.json and the sdkVersion on app.json


#6

I am also having this problem suddenly, today. I am using expo: v 20.0.0 and react-native: v 0.47.0.
One interesting point is it’s only while in dev mode, on my iPhone 6 SC. My colleagues iPhone 6s does not have the issue. But for both of us, once published to Expo the issue does not show up.


#7

I just created a brand new expo project and copied the old files on to it.

Here are my latest package.json & app.json versions. Hope it helps.

{
“name”: “Hello-21-1”,
“version”: “0.0.0”,
“description”: “Hello Expo!”,
“author”: null,
“private”: true,
“main”: “node_modules/expo/AppEntry.js”,
“dependencies”: {
“expo”: “^21.0.0”,
“react”: “16.0.0-alpha.12”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-21.0.2.tar.gz”,
“axios”: “^0.16.2”,
“latlng-to-zip”: “^0.0.1”,
“lodash”: “^4.17.4”,
“react”: “16.0.0-alpha.12”,
“react-addons-update”: “^15.6.0”,
}
}

app.json

{
“expo”: {
“name”: “App”,
“description”: " App",
“slug”: “delete-app”,
“privacy”: “unlisted”,
“sdkVersion”: “21.0.0”,
“version”: “1.0.0”,
“orientation”: “portrait”,
“primaryColor”: “#cccccc”,
“icon”: “./assets/icons/app-icon.png”,
“loading”: {
“icon”: “./assets/icons/loading.png”,
},
“packagerOpts”: {
“assetExts”: [“ttf”, “mp4”]
},
“ios”: {
“supportsTablet”: true
}
}
}

Hey anybody could please tell me how to resolve this ? https://goo.gl/gwbu9W


#8

I was having the issue using create-react-native-app. I switched to a full expo app and it’s working now.
Thanks for the help!


#9

were you able to solve this issue?


#10

yes, i gave you the list of package & their version number above that worked for me.


#11

Following the steps here solved my issues:
https://github.com/shoutem/ui/issues/241#issuecomment-298602614

edit package.json and app.json //replace version numbers as explained by @harryp

cd to directory
’rm -rf node_modules’ //get rid of previous module installations based on 0.44.0
npm install
react-native link
npm start