Standalone Build Failed! no previous Notification key, and couldn't find identities

First when i run expo build:ios
I provided Path to P12
Let the expo do the Push Notifications (which is strange that it says couldn’t find any previous notification key)
Then Provided the P8 file.
I received a failed build, and when i looked why it failed, it says error: codesign ident not present in find-identity: **********
Looking for identities matching “(*******)”
0 valid identities found

I checked my developer account, and the App ID matches the identities. So i do not know why it couldn’t find it, or am i looking at the wrong thing when understanding why it failed.
All i wanted to do is to update my ios mobile app

Hey @joelam76,

Can you run expo credentials:manager, select ios and see what is listed for the Apple credentials you have generated?

Cheers,
Adam

Hello @adamjnav,
so i ran expo credentials: manager, and selected ios
there’s two credential that’s generated, both with the same apple team ID, but the first one does not have provisioning profile, whereas the second one does. Which i am assuming was because i had expo provide everything to grab the ipa file, which it works. But on my apple development account i have two different identifier and keys.
I also went on and provided the apple distribution certificate while on the manager, but i got an error with apple context not initialized.
I also don’t know how to provide the path to P8 file, since the key is expo generated.

Thank you for responding,
Joe Lam