TestFlight not getting exp publish --clear updates

#1

EDIT: Fixed, see below in my reply on 1/9…

On xcode, I archive and upload a new build just fine.

I make changes to my CRNA (simple change on the UI) and run exp publish --clear to get a fresh expo bundle.

But, I do not see my changes on the TestFlight app. I’ve even deleted the TestFlight version that was out there, built a new one and reinstalled my app fresh. I do not see my changes.

What am I missing?

Through expo.io, scanning a QR Code, I do see my changes on Android through the Android Expo app. What’s wrong with TestFlight not picking up my changes?

0 Likes

#2

Can you check the contents of EXShell.plist in your Xcode project and ensure that the url inside the plist matches the url you see when you run exp publish?

0 Likes

#3

Yes, I’ve made sure they match. I’ve tried changing the url to a release-channel exp publish to sort of hope it purges a cache. That didn’t work.

That’s the idea right - the exp publish should just give something new for my testflight app to look at, right? It’s as simple as changing a js file, exp publish, and reload TestFlight app, right?

0 Likes

#4

Fixed:

I’m not entirely sure what resolved this but…

  1. In app.json, I used a new slug value
  2. In xcode, I increased the value of the bundle version in Info.plist
  3. In xcode, I referenced the new slug name in the EXShell.plist

It’s possibly some combination of those. I can’t imagine having to point to a new slug every time I make a change. But, it seems like my expo files were stuck on the old slug.

0 Likes

closed #5

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

0 Likes