Unable to build Ad Hoc app - Unexpected token name «_000_000», expected punc «,»

Hi,

I’ve created an Expo react native app, and need to deploy it Ad Hoc (not to the App Store) under an Apple Developer Enterprise Program.

I’m creating the Apple Provisioning Profile on the Apple Developer web interface (this is displaying 2022/05/06 expiration), downloading the .mobileprofile file, and the providing the path to Expo CLI. I always have the warning “Unable to validate specified profile”, and the Profile in Apple Developer web interface becomes Invalid (see second screenshot).

I don’t know if it’s related, but after that, I always have an error that seems to be coming from uglify-es: Unexpected token name «_000_000», expected punc «,»

Should I try to configure Terser instead of uglify-es?
Do you have any clue about this issue, and how to fix it?

Thank you very much for your help in advance!

Best regards,
Pierre Avinain


Expo Diagnostics:

  Expo CLI 4.4.3 environment info:
    System:
      OS: macOS 11.0.1
      Shell: 5.8 - /bin/zsh
    Binaries:
      Node: 14.16.0 - ~/.nvm/versions/node/v14.16.0/bin/node
      Yarn: 1.22.4 - /usr/local/bin/yarn
      npm: 7.9.0 - ~/.nvm/versions/node/v14.16.0/bin/npm
    Managers:
      CocoaPods: 1.10.1 - /Users/pierreavinain/.rbenv/shims/pod
    SDKs:
      iOS SDK:
        Platforms: iOS 13.5, DriverKit 19.0, macOS 10.15, tvOS 13.4, watchOS 6.2
    IDEs:
      Android Studio: 4.1 AI-201.8743.12.41.7199119
      Xcode: 11.5/11E608c - /usr/bin/xcodebuild
    npmPackages:
      expo: ~40.0.0 => 40.0.1 
      react: 16.13.1 => 16.13.1 
      react-dom: 16.13.1 => 16.13.1 
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2 
      react-native-web: ~0.13.12 => 0.13.18 
    npmGlobalPackages:
      expo-cli: 4.4.3
    Expo Workflow: managed

If you are providing your own files, then I suggest not providing apple credentials. Code there expects app store provisioning profile and might be invalidating your profile as a side effect.

I’m not sure about the reason why you are seeing that error at the end, it seems to be happening during publishing, it’s not related in any way to credentials

Thank you for your answer.

Using terser instead of uglify-es resolved my issue, following this doc:
https://docs.expo.io/guides/customizing-metro/#using-terser

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.