Unable to disable Live Reloading to enable Hot Reloading

#1

What do I do? I need to work on some UI and Hot Reloading will be super beneficial. Live Reloading is enabled, but it says unavailable here. I can’t disable it to enable Hot Reloading. :neutral_face:

1 Like
#2

Having the same issue. Live reload seems to work but UI button is blocked hence can’t enable hot reload. Any suggestions?

1 Like
#3

You can tap on the (i) to see why. It’s probably because

  1. dev=false in xde or exp
  2. live reload and hot reload are mutually exclusive
#4

@jesse It always shows me #2 when I click on (i). Asks me to disable LR to enable HR. :neutral_face:

#5

Changing development mode a couple of times from prod to dev and offloading the Expo app from memory solved the issue for me. Make sure you set the development flag to dev. I’ve used CRNA to create the app so changing the flag is done via console for me by pressing d

#6

No luck, still I keep trying. :confused:

#7

make sure you have development mode enabled. close and reopen expo app after changing to enable development mode once you have switched over. then you can use hmr

1 Like
#8

Works now. Thank you so much Brent :heart: