Unable to find line number of errors with new version of expo

Hello,

By upgrading to expo sdk 33, I realized that there is no more indication concernning file name and line number of errors…

It is now complicated to spot and fix bugs with the provided informations :

Have I missed something?

hi there! it looks like the error you are seeing is on the native side and so it cannot point specifically to a line in javascript that caused it.

we recommend against using react-native’s built in CameraRoll API - it is not well maintained, it is missing a lot of features, and it doesn’t integrate nicely with other APIs like filesystem and asset. instead, you should switch your code over to use expo-media-library: https://docs.expo.io/versions/latest/sdk/media-library/ - you’ll be better off!

Hi ! Thanks a lot for the answer. I want to allow multiple selection but currently ImagePicker doesn’t allow this. So I had to use another component found on github. But this component is using CameraRoll…

Notae: There is a feature request that suggests to allow multiple selection with ImagePicker : https://expo.canny.io/feature-requests/p/imagepicker-support-allowsmultipleselection

1 Like