Unable to resolve module 'react-native-screens.js' in year-old snack

Hi I am trying to use this snack that was created for Harvard cs50 online course: https://snack.expo.io/@jhhayashi/project2-solution.

Unfortunately the snack no longer seems to work because of an issue with a package it seems. Almost none of the code is exposed for this snack. Is there any way to resolve this error so that we can view the snack?

Thanks!!

i got it working on the web device here https://snack.expo.io/@awl92/jordans-movie-browser

The project it’s referencing is written for Expo SDK 35 and React Navigation 2.
I suggest you clone that project locally and upgrade it to SDK 39 (or at least 36) and React Navigation 4.

1 Like

thanks. i tried doing that. i got it working at least in the web device in the snack by doing something similar

1 Like