Uncaugh Error: undefined is not a function (near '...babelHelpers.applyDecoratedDescriptor...')

#1

Hi,

I’m using expo build:android, but after the build ready, the apps stuck then show this error. Anyone has resolution ?

#2

Hey @ochansan,

What SDK version are you building for? Also, can you try running your project with expo start --no-dev --minify and see if you can replicate this error?

Cheers,

Adam

#3

Hey @adamjnav

I’m using “sdkVersion”: “32.0.0” …
i’m not sure how i recovered from this error, it doesn’t appear again.
Here’s my package.json

"dependencies": {
        "@babel/core": "^7.0.1",
        "@babel/preset-env": "^7.0.0",
        "@babel/preset-react": "^7.0.0",
        "@babel/runtime": "^7.3.0",
        "@expo/vector-icons": "^9.0.0",
        "acorn": "^6.0.5",
        "autobind-decorator": "^2.4.0",
        "color": "^3.1.0",
        "crypto-js": "^3.1.9-1",
        "expo": "^32.0.1",
        "jest-junit-reporter": "^1.1.0",
        "lodash": "^4.17.4",
        "moment": "^2.18.1",
        "native-base": "^2.10.0",
        "react": "^16.6.3",
        "react-native": "https://github.com/expo/react-native/archive/sdk-31.0.0.tar.gz",
        "react-native-datepicker": "^1.6.0",
        "react-native-gesture-handler": "^1.0.12",
        "react-native-htmlview": "^0.13.0",
        "react-native-swiper": "^1.5.13",
        "react-native-tab-view": "^1.3.1",
        "react-native-vector-icons": "^6.1.0",
        "react-navigation": "^3.0.0",
        "webpack": "^3.12.0"
    }

please close this topic. Thanks.

1 Like
closed #4