Update SDK on Standalone App


#1

So my standalone app still uses SDK 12.0.0, but I want to update to 15.0.0.

I saw in the docs under Building Standalone Apps that “as long as you don’t change the sdkVersion version in exp.json your standalone app will get the new code next time users open the app” so I’ve avoided updating till now.

What is the Expo approved way to update the SDK on a standalone app?

I’ve tried to rerun the building process:

exp build:ios

but get this message:

[exp] Making sure project is set up correctly...
[exp] Your project looks good!
[exp] Checking if current build exists...

[exp] No currently active or previous builds for this project.
[exp] Checking for existing Apple credentials...
[exp] Validating Apple credentials...
[exp] Credentials valid.
[exp] Validating distribution certificate...
[exp] Error validating credentials. You may need to clear them (with `-c`) and try again.
[exp] Unable to validate credentials: Internal error occurred. Please try again in a few minutes or contact support.

#2

Hi @brendobrian, would you mind hopping on slack and pinging me about this? (@skevy)


#3

Definitely. Sounds good.


#4

Solved! I hadn’t accepted the updated ‘Apple Developer Program License Agreement’ found in iTunes Connect (rarely have to go there thanks to Expo). I just had to login, review, and accept the updated agreement.

Big ups to @skevy for the guidance :wink:


#5

I skevy, I have the same issue and clearing it with -c says bad command please help