Upgrade IPA via TestFlight didn't upgrade

#1

This is a weird one.

I upgraded to SDK28, built a new IPA and uploaded it to TestFlight.

I upgraded via TestFlight, and TestFlight showed the new version number, but the app itself was still the previous release. TestFlight showed all up-to-date with no upgrade available.

I then uninstalled and reinstalled via TestFlight again, now it was the new release.

So TL;DR is: TestFlight upgrade didn’t work, had to uninstall to upgrade to the new version. Will my users experience the same when they upgrade to SDK28? I don’t to tell them they have to uninstall before upgrading.

EDIT: Could it be because the Expo account name changed, as I transfer it to a client’s Expo account?

Thanks

#2

you’ll need to describe in more detail what exact steps you took around changing the expo account name. for what it’s worth, you can’t really do this: Changing usernames, transferring projects

#3

Thanks that’s a useful link.

To change usernames I did this:

  • Fetch certs while logged into initial username: exp fetch:ios:certs
  • Log in as new usernae: exp login
  • Create a new iOS build 1.2.0 providing the previous certs: exp build:ios
  • Upload IPA to TestFlight
  • Received notification on phone that upgrade is available (1.2.0)
  • Upgraded via TestFlight, TestFlight shows 1.2.0
  • Open upgraded app - is still showing old version 1.1.0 and contains no new code
  • Check TestFlight again - shows new version 1.2.0 and no upgrade available.
  • Uninstall app
  • Install app again via TestFlight.
  • Open app - now showing 1.2.0 and contains the recent features.

Thanks a lot for any hints

#4

can you link me to the url for the project on the old and new account?

#5

Update: I’ve just done a TestFlight upgrade on another device (old iPad 2) and again TestFlight “upgraded” to the new version. But on opening it’s still the old app version.

TestFlight app reports the correct version but when you run it it’s on old one based on an older SDK, and even based on a different Expo username / URL. Could it be that the IPA upgrade silently fails because the Expo username / experience URL has changed?

I’ve tried shutting the app down, rebooting the iPad. The only way to do the upgrade is uninstall the older app then reinstall via TestFlight, rather than upgrading between the 2 versions.

#6

What does the updates configuration look like inside app.json?

#7

Hi, thanks for the reply:

    "updates": {
      "enabled": true,
      "checkAutomatically": "ON_ERROR_RECOVERY",
      "fallbackToCacheTimeout": 0
    },
#8

Hi @mlight - it sounds like you’re experiencing this issue, the fix for which was deployed a few weeks ago. Unfortunately, both the new and old IPA need to have been built after the fix was deployed in order to get the correct behavior. So going forward, you shouldn’t see this issue anymore, but will need to deal with it for this one upgrade cycle. Really sorry for the inconvenience :disappointed:

closed #9

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.