Uploading App To TestFlight

Hi all,

Recently built my expo app using the expo build:ios command and wanted to send it off up to TestFlight.

However when I was uploading the .ipa file to TestFlight using the command line, I was given an error ERROR ITMS-90786: "Invalid Entitlement. Apps that contain the 'com.apple.developer.coremedia.hls.low-latency' entitlement must be built with the iOS 13.0 SDK or later.".

I just wanted to see if anyone could point me in the right direction, what am I doing wrong when I build the file and how do I comply with this entitlement?

Kind Regards,
George

Actually, I fixed this issue by doing expo build:ios --clear-provisioning-profile , I also deleted my bundle identifier I previously used in the Apple Developer settings. I let expo do the hard work and generate all the new keys, certificates, etc… Then downloaded the .ipa file generated by the build using the link expo gave me then proceeded to use xcrun altool --upload-app -f your-ipa.ipa -u email@address.com command in Terminal, this uploaded the ipa to App Store Connect as Application Loader isn’t used anymore and was made redundant my Apple in the latest Xcode 11 release.

Hope this helps someone.

1 Like

FYI, with the latest version of expo-cli, expo upload:ios should apparently work again.

1 Like

Yes it works. However there is one more way for iOS user is “Transporter”

Note: Application loader was removed from Xcode 11.0 + now using Transporter instead.

i have the same issue, but still didn’t work, do you add some infoPlist about the low latency permission in app.json ? if yes then how?