Urgent : After dettaching from expo, I can't get to work on android

#1

I had to detach so I could use expo payment - now in android studio when I open the project I get a error

Project with path ‘:expo-core’ could not be found in project ‘:expo-payments-stripe’.

I can’t build it with using the cli ./gradlew installDevMinSdkDevKernelDebug
Not sure what to do ?

#2

it was working smooth on my android phone when it was running on android version 6.0.1 however as I have updated to android version 7.1.1 whenever now I am opening the app it only loads a blank screen on the start up and crashes after a while automatically. How do I fix it?
with regards
shareit ucbrowser

#3

Got it to work

Make sure to add to your settings.gradle.

include ‘:expo-core’

project(’:expo-core’).projectDir = new File(rootProject.projectDir, ‘…/node_modules/expo-core/android’)

Expo team can you PLEASE update your documents. Also I saw there is a separate permission/notification module as well do I need THOSE for notifications to work. IMO you guys should create a document for expo kit that outlines what needs to be done if you have had these things installed and working before detaching it will SAVE a lot of headache and less questions on the forum.

#4

Check below

closed #5

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.