What version of Xcode is expo using when building IOS apps?


#1

I’m getting an error uploading my standalone app to the App Store.

Application Loader gives me an error saying: ERROR ITMS-90596: “Invalid Bundle. The asset catalog at ‘Payload/ExpoKitApp.app/Assets.car’ can’t be processed. Rebuild the app, and all included extensions and frameworks, with the latest GM version of Xcode, and submit it again.”

Not sure how to solve this.

Application loader v: 3.7.1
Xcode version: 9.4.1
App sdk: 29


#2

I got the same problem.
“expo”: “^30.0.1”,
“react”: “16.3.1”,
“react-native”: “https://github.com/expo/react-native/archive/sdk-30.0.0.tar.gz”,


#3

Hello guys,

I think we know what the problem is, at this very moment you can fix it by bumping the SDK version to 31 and by rebuilding your apps with expo build:ios. I’ll be working on fixing this issue for the old SDK versions. Sorry for the inconvenience!


#4

Upgrading Xcode fixed this for me


#5

Thanks for your advice. It helped me as well.


#6

Alright, so I can also confirm that upgrading Xcode to version 10 is required to upload iOS standalone app to the App Store.


#7

Will you still fix this for older SDK versions to work with older versions of Xcode?


#8


#9

Is there likely to be a fix for applications using an SDK earlier than 31?

This is for apps built using the Expo online build service, not detached. The builds have not been uploadable for the last couple of days.


#10

Upgrading xcode to version 10 (from 9) fixed this for me. Thanks for the tip @omorhefere and @thehappy!


#11

@mlight Unfortunately no, there won’t be “a fix” for older SDK versions. We use the same virtual machines for building apps with all SDK versions. This means we use the same Xcode version for building all users apps.


#12


#13

OK, it might be worth documenting that Expo users can no longer use MacOS < 10.13.6 and XCode < 10.1.

Or I suppose they’ll end up here when they google the error message.


#14

I have mac OS 10.13.6 and xcode version 9.3, i have modified sdk version 31 , but still getting this error. Please suggest ASAP!


#15

Hey @cashpack,

As mentioned above you need to update to Xcode 10+ to be able to upload. Sounds like you’re still on 9.3.

Cheers,

Adam


#16

using SDK 31 and ApplicationLoader 3.7.2 and still getting the error.

edit: Expo is handling all the credentials for the IPA build, dunno if it’s relevant.

edit2: nevermind, updated XCode to version 10+ (was 9.4.1) and it worked.


closed #17

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.