When to use 'expo-image-picker'

#1

Just upgraded to 32 from 25. I used to use ImagePicker from expo package and now I am getting an error.

..ImagePicker/dbfee92d-6711-4ffa-a39f-844d1faf825b.jpg exposed beyond app through ClipData.Item.getUri()

I found this issue describing the problem https://github.com/expo/expo/issues/3706, but it is related to ImagePicker from ‘expo-image-picker’ package and not ‘expo’ package.

My question is are ejected apps counted as bare React Native apps and do I need to now switch to ImagePicker from ‘expo-image-picker’

#2

Hi @artemmoroz,

Have you already followed the upgrade instructions for Expokit? Especially the changes for upgrading if you were on an SDK before 31

Edit: I’ve also seen instances of this issue when there’s a problem with Permissions, so I’d check to make sure your bases are covered there, as well

#3

@charliecruzan
Well I took a rather dramatic approach to upgrade and created a new expo project then copied all the JS to it then ejected.
But is it ok to use import { ImagePicker } from 'expo' and not
import * as ImagePicker from 'expo-image-picker'; on an ejected app? I was not sure if ejected app was counted as a bare app.

Thanks.

#4

Everything you’ve built should stay working when you eject, so you shouldn’t have to change that

-Charlie

#5

It seems like the error I am seeing is related to https://github.com/expo/expo/pull/3743, but the PR clearly addresses expo-image-picker. Is it possible that the same change can be made to ImagePicker from expo? If so can you point me in the right direction please?

Thank you @charliecruzan