When will expo support proper upgrade guide for android in expokit?

#1

I am always upgrading from new expo project from sdk24 because of changes in expo.
This really takes me a lot of time to review all the native dependencies I’ve created.

New expo sdk is released which is 27 and I am really afraid of upgrading from new expo project and move all my sources there again. That caused many bugs everyday because everytime I am missing something because there are many native dependencies I’ve made. For ios, I could upgrade just from my own project but I’ve never made it for android from sdk24. Document in below link is never updated from there. It won’t work as it is told in below link. Please provide us new upgrade guide for android.

https://docs.expo.io/versions/v27.0.0/expokit/expokit#upgrading-expokit

#2

Hi @dooboolab - a new upgrade guide is in the works as we speak (type?). We know it’s long overdue and we’re really sorry for the wait and the trouble. Keep checking back – it should be up soon!

1 Like
#3

@esamelson I was longtime waiting for this since expo sdk 24. I’m keep checking and checking everyday.

#4

Hi @dooboolab - this is landed now. I don’t think it’s deployed to docs.expo.io yet but you can view it here for now: https://github.com/expo/expo-docs/blob/33f300974ba5116d736ede0119fd3af326390d0d/versions/v27.0.0/expokit/expokit.md

1 Like
#5

@esamelson Another question… Do you have any idea why this is keep appearing in expo sdk 27? I know it is react-native issue but it isn’t solved in github issue.

17:26:18 [exp] Warning: isMounted(...) is deprecated in plain JavaScript React classes. Instead, make sure to clean up subscriptions and pending requests in componentWillUnmount to prevent memory leaks.
- node_modules/react/cjs/react.development.js:92:19 in printWarning
- ... 8 more stack frames from framework internals

Related here.

1 Like
#6

@dooboolab - this is just an upstream issue in react-native that we don’t have any control over. You can do:

import { YellowBox } from 'react-native';

YellowBox.ignoreWarnings(['Warning: isMounted(...) is deprecated', 'Module RCTImageLoader']);

to make it go away, or import expo@27.0.1 which sets this automatically for you.

#7

Where exactly is this import and call begin placed?

#8

@multitown - anywhere in the root file of your project should suffice.

closed #9

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.