Which JS APIs are supported in Expo runtimes?


#1

Hi,

I’m looking to understand which JS APIs are supported in the Expo runtime.

For instance, I’d love to find a source of truth that describes things like intl (https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Intl) is supported in the iOS Expo runtime, but not the Android Expo runtime. (Not sure if this is expected, but seems that way.)

I might have missed it, but didn’t find anything in the docs at https://docs.expo.io/versions/latest/index.html. Does anyone know where to find this info?

Thank you,
AJE

PS This is a more general form of the question asked in Expo attached vs detached: different js runtime?.


#2

On iOS: Expo uses the copy of JavaScriptCore that comes with the device. This differs across iOS versions but it matches what Safari on the device supports.

On Android: Expo currently includes a copy of JSC that is similar to iOS 8’s version of JSC. In the future (hopefully in 2018) we’ll upgrade JSC but it is not simple to do responsibly.